$re = '/(UNION) S/m';
$str = 'SELECT * FROM Tabelle1 UNION ALL SELECT * FROM Tabelle2 UNION SELECT * FROM Tabelle3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);