#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<=\{\{Infobox(?:[^{}]|\{\{(?:[^{}]|\{\{[^{}]*\}\})*\}\})*)\[\[ *(?:image|fi(?:le|chier)) *: *([^\|\]]*)[^\]]*\]\]"
Local $sString = "{{Infobox xyz" & @CRLF & _
"|aaa= Xyz {{foo| {{A NESTED TEMPLATE}} other stuff}}" & @CRLF & _
"|bbb= [[Xyz]]" & @CRLF & _
"|ccc=[[File:xyz.jpg|thumb|Xyz.]]" & @CRLF & _
"|bbb= [[Xyz]]" & @CRLF & _
"|ccc=[[Image:xyz.jpg|thumb|Xyz.]]" & @CRLF & _
"|ddd= {{lang|en|xyz}}" & @CRLF & _
"}}" & @CRLF & _
"" & @CRLF & _
"[[File:abc.jpg|thumb|Abc.]]"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)