$re = '/^(?![\S\s]*should not exist)/i';
$str = 'This is a block of text
with many new lines
but in this block
some words should not exist
such as the line above this one';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);