re = /^(?![\S\s]*should not exist)/i
str = 'This is a block of text
with many new lines
but in this block
some words should not exist
such as the line above this one'
# Print the match result
str.match(re) do |match|
puts match.to_s
end