$re = '/^(?!0+)\d{2,4}$/m';
$str = '0
00
000
0888
0000
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);