use strict;
my $str = 'Lord John Cain asked...
Ser John has...
Lady Agatha and Lord John are...
Lady Agatha Cain was...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating...
He looked at them. Cain was walking...
Cain is...
Outside the castle, in a small courtyard, a page was leading Ser
John and his horse into the stables.
Yes, my lord... My Lord Tom, that is...
';
my $regex = qr/\b(?<!\S)(?:(Lord|Lady|Ser)\s+)?(Agatha|John)?(?:\s*(?<=\b)(Cain))?(?<=\S)\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}