$re = '/\b(?<!\S)(?:(Lord|Lady|Ser)\s+)?(Agatha|John)?(?:\s*(?<=\b)(Cain))?(?<=\S)\b/i';
$str = 'Lord John Cain asked...
Ser John has...
Lady Agatha and Lord John are...
Lady Agatha Cain was...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating...
He looked at them. Cain was walking...
Cain is...
Outside the castle, in a small courtyard, a page was leading Ser
John and his horse into the stables.
Yes, my lord... My Lord Tom, that is...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);