# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\+?1?[-.\s]?)(\d{3})([-.\s])(\d{3})\2(\d{4})$/(\1) \3 \4/gmx;t' <<< "+1-555-235-2444
1-555-235-2444
1.555.235.2444
1 555 235 2444
555-235-2444
(555) 234-2341
5552342341
555 2341234
555-2341234"