const regex = /^(?:\+?1?[-.\s]?)(\d{3})([-.\s])(\d{3})\2(\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+?1?[-.\\s]?)(\\d{3})([-.\\s])(\\d{3})\\2(\\d{4})$', 'gm')
const str = `+1-555-235-2444
1-555-235-2444
1.555.235.2444
1 555 235 2444
555-235-2444
(555) 234-2341
5552342341
555 2341234
555-2341234`;
const subst = `(\1) \3 \4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);