package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+:\d{2}:\d{2}$`)
var str = `01:00:00
1:00:00
30:21:21
330:21:21
1330:21:21
11330:21:21
0:0:0
0:
0
1
30:211:211
30:2111:2111
a:d:d
asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}