use strict;
my $str = '01:00:00
1:00:00
30:21:21
330:21:21
1330:21:21
11330:21:21
0:0:0
0:
0
1
30:211:211
30:2111:2111
a:d:d
asd';
my $regex = qr/^\d+:\d{2}:\d{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}