import Foundation
let pattern = #"^(?<forename>.+?)\s(?<surname>\w+)\nBirth\n(?:(?<birth_day>(\d{1,2}|unknown))\s(?<birth_month>\w{3})\s(?<birth_year>\d{4})|\bunknown\b)\n(?<birth_location>.+?\n)?Death\n(?:(?<death_day>(\d{1,2}|unknown))\s(?<death_month>\w{3})\s(?<death_year>\d{4})(?:\s*\(aged\s*(?<age>\d+)\))?|unknown)\n(?<death_location>.+?)\nBurial\n(?<cemetery_name>.+?)\n(?<cemetery_location>.+?)\n(?:Show MapGPS-Latitude:\s*(?<latitude>-?\d+\.\d+),\s*Longitude:\s*(?<longitude>-?\d+\.\d+))?\n?(?:Plot\n(?<plot>.+?)\n?)?Memorial ID\n(?<memorial_id>\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Frederick Clarke
Birth
6 Feb 1871
Death
7 Nov 1952 (aged 81)
Sheffield
Burial
Crookes Cemetery
Sheffield, Metropolitan Borough of Sheffield, South Yorkshire, England
Show MapGPS-Latitude: 53.384024, Longitude: -1.515043
Plot
MM 7848
Memorial ID
237065233
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)