#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "if %{HTTP_HOST} regimatch t-sapportal.heijmans.com [AND]" & @CRLF & _
"if %{SERVER_PORT} = 7000" & @CRLF & _
"SetHeader x-sap-webdisp-target-sid HET"
Local $sString = "hu Jan 16 2018 00:15:06 mailsv1 sshd[5258]: Failed password for invalid user testuser from 194.8.74.23 port 3626 ssh2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")