use strict;
my $str = 'The regular expression above will every character that is either a captial "C", a lower case "a", or a lower case "t". The square brackets are used to indicate a list of characters to match (like saying "I want to find any of the following items: \'C\', \'a\' or \'t\'"). To see all matches, click "preg_match_all" to the right (it\'s a long list).';
my $regex = qr/[Cat]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}