// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[Cat]").unwrap();
let string = "The regular expression above will every character that is either a captial \"C\", a lower case \"a\", or a lower case \"t\". The square brackets are used to indicate a list of characters to match (like saying \"I want to find any of the following items: 'C', 'a' or 't'\"). To see all matches, click \"preg_match_all\" to the right (it's a long list).";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}