$re = '/<script([^>]*)?>.*?<\/script>/';
$str = '1<script type=\'text/javascript\'>2</script>3<script type=\'text/javascript\'>3</script>5<script>..</script>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;