re = /^(?!.*([wdhml]).*\1)\d*\.?\d+[wdhml](?: \d*\.?\d+[wdhml])*$/mi
str = '1w 1d
1w 1h 1m
1d 1h 1m
1h 1m
1w 1m
1w
1w 1w
1w1w
1.5w .5d
.5m
5m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end