# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\R+/\n/gu;t' <<< "This is text line 1
This is text line 2
This is text line 3"