re = /\R+/
str = 'This is text line 1
This is text line 2
This is text line 3'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result