$re = '/<span class=""*QuellonStartSession""*>(.+?)<\/span>(.+?)<span class=""*QuellonEndSession""*>.+?<\/span>/i';
$str = '<span class="QuellonStartSession">FirstSession</span><span class="QuellonStartSession">SecondSession</span>SomeContent<span class="QuellonEndSession">EndSecondSession</span>SomeContent...<span class="QuellonEndSession">EndFirstSession</span> ....Content...<span class="QuellonStartSession">SomeSession</span>Content<span class="QuellonEndSession">EndSomeSession</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);