re = /^[^.]*(?:(?:\.[^\.]*){0,1})$/m
str = 'lo.cat.tion
location
loca.tion
loca_caca
loca.cas.cas.acs
asd.asd.asas.asd.asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end