// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[([A-Za-z_]+[^\ \]]+)").unwrap();
let string = "[yt] Крутое видео[/yt] на сайте!!!! [CDATAKJHKHJ KJHKJHK] Крутое видео[/youtube] на сайте!!!! [code jhg jhg jhgjh jhg jhgjh gj] тут текст арвлаорпл ва[/code] ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}