#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "ABC|ABc|AbC|Abc|aBC|abC|abc"
Local $sString = "This should match:" & @CRLF & _
"ABC" & @CRLF & _
"ABc" & @CRLF & _
"AbC" & @CRLF & _
"Abc" & @CRLF & _
"aBC" & @CRLF & _
"abC" & @CRLF & _
"abc" & @CRLF & _
"" & @CRLF & _
"Text with abc in it should also match. Even if it is within a word like in Barabc Obama." & @CRLF & _
"" & @CRLF & _
"This must not match:" & @CRLF & _
"aBc" & @CRLF & _
"cba" & @CRLF & _
"aaa" & @CRLF & _
"bbb" & @CRLF & _
"ccc" & @CRLF & _
"bac" & @CRLF & _
"ABBA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")