# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+\/src\/|\G([^\/]+)\/(?:(?=[^\/]+\/.*([.]))|[^\/]+$)/$1$2/g;t' <<< "/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as"