$re = '/\s{1}[A-Z]{2}[^A-Z]/m';
$str = 'XX2089 DDA POS PURCH 04/15 20:22 AMAZON.COM*MZ2MN SEATTLE WA 00000101 4OXR9EWWAT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);