re = /\.(?![^.]*$)/m
str = './folder/thisisa.test/file.cxx.h'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result