package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(at){2}`)
var str = `There is nothing to match in this sentence because it doesn't have the repeating pattern. The pattern is the letters "at" together, using the parenthesis to group the letters we want to look for, repeated two times.
It will find a match in the following: "The machine gun went ratat."
No match here because of the spaces: "The machine gun went rat at"
This will partially match since it is looking for "at" twice in a row, but will not match the full repetition since it actually repeats three times: "The machine gun went ratatat." To fix this, we could change the expresion to "(at){2,}" which says find the letters "at" repeated two or more times.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}