// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(at){2}").unwrap();
let string = "There is nothing to match in this sentence because it doesn't have the repeating pattern. The pattern is the letters \"at\" together, using the parenthesis to group the letters we want to look for, repeated two times.
It will find a match in the following: \"The machine gun went ratat.\"
No match here because of the spaces: \"The machine gun went rat at\"
This will partially match since it is looking for \"at\" twice in a row, but will not match the full repetition since it actually repeats three times: \"The machine gun went ratatat.\" To fix this, we could change the expresion to \"(at){2,}\" which says find the letters \"at\" repeated two or more times.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}