import Foundation
let pattern = #"(at){2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
There is nothing to match in this sentence because it doesn't have the repeating pattern. The pattern is the letters "at" together, using the parenthesis to group the letters we want to look for, repeated two times.
It will find a match in the following: "The machine gun went ratat."
No match here because of the spaces: "The machine gun went rat at"
This will partially match since it is looking for "at" twice in a row, but will not match the full repetition since it actually repeats three times: "The machine gun went ratatat." To fix this, we could change the expresion to "(at){2,}" which says find the letters "at" repeated two or more times.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)