using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9\/\–\?\:\(\)\.\,\‘\+\s]{0,140}";
string input = @"Hallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}