using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3}([ .-])?\d{3}([ .-])?\d{4}|\(\d{3}\)([ ])?\d{3}([.-])?\d{4}|\(\d{3}\)([ ])?\d{3}([ ])?\d{4}|\(\d{3}\)([.-])?\d{3}([.-])?\d{4}|\d{3}([ ])?\d{3}([ .-])?\d{4}";
string substitution = @"";
string input = @"(123).234.4567
(123)-234-4567
(617) 495-1797
(617) 495 1797
(617) 4951797
6174951797
617 4951797
123.234.4567
123-456-4567
123.123-1234
123.123-1234
123 123-1234
123 123 1234";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}