re = /(?<=^|\s)\d{1,3}(?:,\d{3})*(?:,\d+)?(?=\s|$)/m
str = '980,232 905,903 889,614 881,145 2,343,435 3,435,123 84,325 4,43,52352366 14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end