#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([a-zA-Z" ]+ *, *[1-9][0-9]?(\n|$))+$"
Local $sString = "Sam "The Man" McAdams , 9" & @CRLF & _
"Sam "The Man" McAdams , 9" & @CRLF & _
"Sam "The Man" McAdams , 9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")