using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^\\""]*(?:\\[\w\W][^\\""]*)*""|'[^\\']*(?:\\[\w\W][^\\']*)*'|(:\w+)";
string input = @"select * from a where id = :myId3;
to_timestamp_tz(:FROM_DATE, 'YYYY-MM-DD\""T\""HH24:MI:SS')
TO_CHAR(ep.CHANGEDT,'yyyy=mm-dd hh24:mi:ss')
user input invalid string ' :shouldIgnoreThisNamedParam ' in a string";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}