const regex = /"[^\\"]*(?:\\[\w\W][^\\"]*)*"|'[^\\']*(?:\\[\w\W][^\\']*)*'|(:\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^\\\\"]*(?:\\\\[\\w\\W][^\\\\"]*)*"|\'[^\\\\\']*(?:\\\\[\\w\\W][^\\\\\']*)*\'|(:\\w+)', 'gm')
const str = `select * from a where id = :myId3;
to_timestamp_tz(:FROM_DATE, 'YYYY-MM-DD\\"T\\"HH24:MI:SS')
TO_CHAR(ep.CHANGEDT,'yyyy=mm-dd hh24:mi:ss')
user input invalid string ' :shouldIgnoreThisNamedParam ' in a string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}