$re = '/^hede$(*SKIP)(*F)|^.*/m';
$str = 'Hoho
Hihi
Haha
hede
addf';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;