$re = '~(?<=<code>).*?\K</code>|<(/?[^\>]+)>~siu';
$str = 'вне тега<p>внутри</p><code><b>жирный</b></code><a href=\'#\'>Ссылка</a>
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;