# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^\s+<span.+lj:user="
([-\w]{1,15})
".+<b>
([-\w\s]+)
<\/b>.+ —\s
([-\.\w\s]+)
<\/div>$
"""
test_str = (" <div>\n"
" <span class=\"ljuser i-ljuser i-ljuser-type-P \" data-ljuser=\"canonf\" lj:user=\"canonf\" ><a href=\"http://canonf.livejournal.com/profile\" target=\"_self\" class=\"i-ljuser-profile\" ><img class=\"i-ljuser-userhead\" src=\"http://l-stat.livejournal.net/img/userinfo.gif?v=17080?v=134.3\" /></a><a href=\"http://canonf.livejournal.com/\" class=\"i-ljuser-username\" target=\"_self\" ><b>canonf</b></a></span> — Растоптать от души.\n"
" </div>\n"
" <div>\n"
" <span class=\"ljuser i-ljuser i-ljuser-type-I \" data-ljuser=\"ext_2056646\" lj:user=\"ext_2056646\" ><a href=\"http://www.livejournal.com/profile?userid=65329483&t=I\" target=\"_self\" class=\"i-ljuser-profile\" ><img class=\"i-ljuser-userhead\" src=\"http://l-stat.livejournal.net/img/icons/facebook-16.png?v=29916?v=134.3\" /></a><a href=\"http://www.facebook.com/profile.php?id=100001197014517\" class=\"i-ljuser-username\" target=\"_self\" ><b>Летающий Котёнок</b></a></span> — Растоптать от души.\n"
" </div>")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.