using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bbrown\b[^o]*(?:o(?!ver\b)[^o]*)*\bover\b";
string input = @"The quick brown fox jumps over the lazy dog over.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}