const regex = /(".*")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(".*")', 'g')
const str = `"http://g01.a.alicdn.com/kf/HTB1FGzVIpXXXXa3XFXXq6xXFXXXK/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g03.a.alicdn.com/kf/HTB1YkHYIpXXXXcXXpXXq6xXFXXXg/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g03.a.alicdn.com/kf/HTB1yS_0IpXXXXcQXpXXq6xXFXXX2/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g02.a.alicdn.com/kf/HTB1fgIaIpXXXXXKXXXXq6xXFXXXV/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg",
"http://g02.a.alicdn.com/kf/HTB1kpjVIpXXXXbhXFXXq6xXFXXXq/2015-новых-мужчин-блузки-без-рукавов-мода-шифон-блузки-леди-шеи-экипажа-воланами-после-открытым-воротником.jpg"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}