import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<img[^<]+class=[\\\"'][^<]*\\s*thumbnail\\s*[^<]*[\\\"'][^<]+>)";
final String string = "<p><img class=\" asdf thumbnail as\" src=\"abc.jpg\" height=\"83\" width=\"131\"></p></p><p><img src=\"def.jpg\" class=\"thumbnail\" height=\"83\" width=\"131\"></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}