$re = '/(<img[^<]+class=[\"\'][^<]*\s*thumbnail\s*[^<]*[\"\'][^<]+>)/i';
$str = '<p><img class=" asdf thumbnail as" src="abc.jpg" height="83" width="131"></p></p><p><img src="def.jpg" class="thumbnail" height="83" width="131"></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);