re = /^((?!['"])[\x00-\x7F])*$/m
str = 'no it\'s all "right lag
no its all right lag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end