#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{{([^},]+)(?:,([^}]+))?}}"
Local $sString = "This is my first example string. {{foo}} This is what it looks like." & @CRLF & _
"This is my second example string. {{1,2}}. This is what it looks like." & @CRLF & _
"This is my third example string. {{a,b}} and {{2}}. This is"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")