package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{([^},]+)(?:,([^}]+))?}}`)
var str = `This is my first example string. {{foo}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{a,b}} and {{2}}. This is`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}