// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<a.*>.*<img.*?<\/a>)").unwrap();
let string = "Text Text Text <a href=\"\">Linktext</a> Text Text Text <a href=\"\"><img src=\"\"></a> Test Test Test
Text Text Text <a href=\"\">Linktext</a><a href=\"\"><img src=\"\"></a> Test Test Test
Text Text Text <a href=\"\"><img src=\"\"></a> Test Test Test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}