$re = '/^((\d)\2){2}$/m';
$str = '1133
4455
9911
5554
3214
111114';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);