use strict;
my $str = 'value: 1.25MG - OM - PO/TUBE - ashaf
value:2.5 MG - OM - PO/TUBE -test
value: 18 UNITS(S)
value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE)
value: 75 MG - OM - PO/TUBE';
my $regex = qr/^value:\s?(\S+(?:\s[^-\n]+)?)(?:\s-\s.*?-([^-\n]*)(?:-.*)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}