using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/.*\/)(\d{3,})(.*)";
string substitution = @"$1{id}$3 // dont print the $2!";
string input = @"/product/1234567890/warranty";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}