re = /[^A-Za-z0-9.@\/ _\xe9\x{e8}-]/
str = 'J\'utilise la commande suivante pour supprimer tous les caractères spéciaux des noms de fichiers à l\'exception de ".", "@", "/", " ", "_", "-", "é" et "è".'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end